[www] Is the website being updated from the monorepo?

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

[www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
Hi,

In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.

Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?

Thanks,
STL

[0] https://reviews.llvm.org/D69363
[1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
It should be but it seems that Sphinx bots for both LLVM and Clang
docs are not working for some reason despite being green on the
buildbot console. I've noticed this earlier as well.

On Fri, Oct 25, 2019 at 11:46 PM Stephan T. Lavavej via cfe-dev
<[hidden email]> wrote:

>
> Hi,
>
> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>
> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>
> Thanks,
> STL
>
> [0] https://reviews.llvm.org/D69363
> [1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05
>
> _______________________________________________
> cfe-dev mailing list
> [hidden email]
> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
In reply to this post by David Zarzycki via cfe-dev
On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
> Hi,
>
> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>
> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>

We are aware and working on getting this fixed.

-Tom

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
[STL]
> Is Clang's website being automatically updated from the monorepo,
> or does it still need to be migrated, or is manual action necessary?

[Kristina Brooks]
> It should be but it seems that Sphinx bots for both LLVM and Clang
> docs are not working for some reason despite being green on the
> buildbot console. I've noticed this earlier as well.

That's useful info, thanks. I didn't even know what to look for.

[Tom Stellard]
> We are aware and working on getting this fixed.

Great, thanks!

STL
_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
In reply to this post by David Zarzycki via cfe-dev
Hi Tom / Mike,

I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.

I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.

Thanks,
Duncan

> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>
> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>> Hi,
>>
>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>
>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>
>
> We are aware and working on getting this fixed.
>
> -Tom
>
>> Thanks,
>> STL
>>
>> [0] https://reviews.llvm.org/D69363
>> [1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05
>>
>> _______________________________________________
>> cfe-dev mailing list
>> [hidden email]
>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>>
>
> _______________________________________________
> cfe-dev mailing list
> [hidden email]
> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
> Hi Tom / Mike,
>
> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>
> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>

It was working and then it stopped again.  We are working on getting it
fixed.

-Tom

> Thanks,
> Duncan
>
>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>
>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>> Hi,
>>>
>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>
>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>
>>
>> We are aware and working on getting this fixed.
>>
>> -Tom
>>
>>> Thanks,
>>> STL
>>>
>>> [0] https://reviews.llvm.org/D69363
>>> [1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05
>>>
>>> _______________________________________________
>>> cfe-dev mailing list
>>> [hidden email]
>>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>>>
>>
>> _______________________________________________
>> cfe-dev mailing list
>> [hidden email]
>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev


> On 2019 Nov  20, at 22:23, Tom Stellard <[hidden email]> wrote:
>
> On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
>> Hi Tom / Mike,
>>
>> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>>
>> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>>
>
> It was working and then it stopped again.  We are working on getting it
> fixed.

Thanks Tom!

> -Tom
>
>> Thanks,
>> Duncan
>>
>>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>>
>>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>>> Hi,
>>>>
>>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>>
>>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>>
>>>
>>> We are aware and working on getting this fixed.
>>>
>>> -Tom
>>>
>>>> Thanks,
>>>> STL
>>>>
>>>> [0] https://reviews.llvm.org/D69363
>>>> [1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05
>>>>
>>>> _______________________________________________
>>>> cfe-dev mailing list
>>>> [hidden email]
>>>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>>>>
>>>
>>> _______________________________________________
>>> cfe-dev mailing list
>>> [hidden email]
>>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>>
>

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
In reply to this post by David Zarzycki via cfe-dev
On Wed, Nov 20, 2019 at 10:23 PM Tom Stellard via cfe-dev <[hidden email]> wrote:
On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
> Hi Tom / Mike,
>
> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>
> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>

It was working and then it stopped again.  We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I've verified that `clang-tblgen -gen-attr-docs` works.

- Michael Spencer
 

> Thanks,
> Duncan
>
>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>
>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>> Hi,
>>>
>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>
>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>
>>
>> We are aware and working on getting this fixed.
>>
>> -Tom
>>
>>> Thanks,
>>> STL
>>>
>>> [0] https://reviews.llvm.org/D69363
>>> [1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05
>>>
>>> _______________________________________________
>>> cfe-dev mailing list
>>> [hidden email]
>>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>>>
>>
>> _______________________________________________
>> cfe-dev mailing list
>> [hidden email]
>> https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
>

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev

_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
On Thu, Dec 19, 2019 at 2:46 PM Michael Spencer <[hidden email]> wrote:
On Wed, Nov 20, 2019 at 10:23 PM Tom Stellard via cfe-dev <[hidden email]> wrote:
On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
> Hi Tom / Mike,
>
> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>
> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>

It was working and then it stopped again.  We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I've verified that `clang-tblgen -gen-attr-docs` works.

- Michael Spencer
 

Still empty.

- Michael Spencer
 

> Thanks,
> Duncan
>
>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>
>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>> Hi,
>>>
>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>
>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>
>>
>> We are aware and working on getting this fixed.
>>
>> -Tom
>>
>>> Thanks,
>>> STL
>>>


_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
As of right now (literally 22:16PST on 2020-01-07) the page at https://clang.llvm.org/docs/AttributeReference.html is alive an well.  I think I have figured out the issues with the old update scripts and I'm hoping this page will continue updating without further issue.  If something breaks just ping me and I'll try my best to get things fixed as quickly as possible.  Also, just an FYI, I am working with the fine folks over at Access Softek on a real long term solution to this problem which will involve bots doing CI work for docs generation and other bots doing CD work to keep the website continuously up to date.

Thanks,
Mike

On Tue, Jan 7, 2020 at 1:11 PM Michael Spencer <[hidden email]> wrote:
On Thu, Dec 19, 2019 at 2:46 PM Michael Spencer <[hidden email]> wrote:
On Wed, Nov 20, 2019 at 10:23 PM Tom Stellard via cfe-dev <[hidden email]> wrote:
On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
> Hi Tom / Mike,
>
> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>
> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>

It was working and then it stopped again.  We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I've verified that `clang-tblgen -gen-attr-docs` works.

- Michael Spencer
 

Still empty.

- Michael Spencer
 

> Thanks,
> Duncan
>
>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>
>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>> Hi,
>>>
>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>
>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>
>>
>> We are aware and working on getting this fixed.
>>
>> -Tom
>>
>>> Thanks,
>>> STL
>>>


_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: [www] Is the website being updated from the monorepo?

David Zarzycki via cfe-dev
On Tue, Jan 7, 2020 at 10:22 PM Mike Edwards <[hidden email]> wrote:
As of right now (literally 22:16PST on 2020-01-07) the page at https://clang.llvm.org/docs/AttributeReference.html is alive an well.  I think I have figured out the issues with the old update scripts and I'm hoping this page will continue updating without further issue.  If something breaks just ping me and I'll try my best to get things fixed as quickly as possible.  Also, just an FYI, I am working with the fine folks over at Access Softek on a real long term solution to this problem which will involve bots doing CI work for docs generation and other bots doing CD work to keep the website continuously up to date.

Thanks,
Mike

Looks like it works. Thanks!

  - Michael Spencer  
 

On Tue, Jan 7, 2020 at 1:11 PM Michael Spencer <[hidden email]> wrote:
On Thu, Dec 19, 2019 at 2:46 PM Michael Spencer <[hidden email]> wrote:
On Wed, Nov 20, 2019 at 10:23 PM Tom Stellard via cfe-dev <[hidden email]> wrote:
On 11/20/2019 09:13 AM, Duncan P. N. Exon Smith wrote:
> Hi Tom / Mike,
>
> I'm curious about the status of this.  I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.
>
> I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.
>

It was working and then it stopped again.  We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I've verified that `clang-tblgen -gen-attr-docs` works.

- Michael Spencer
 

Still empty.

- Michael Spencer
 

> Thanks,
> Duncan
>
>> On Oct 25, 2019, at 16:10, Tom Stellard via cfe-dev <[hidden email]> wrote:
>>
>> On 10/25/2019 03:45 PM, Stephan T. Lavavej via cfe-dev wrote:
>>> Hi,
>>>
>>> In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.
>>>
>>> Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?
>>>
>>
>> We are aware and working on getting this fixed.
>>
>> -Tom
>>
>>> Thanks,
>>> STL
>>>


_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev