libcxx tests broken?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

libcxx tests broken?

Don Hinton via cfe-dev
Hi,

Since yesterday I am getting:

 ********************
 Testing: 0 .. 10.. 20.. 30.. 40.. 50.. 60.. 70.. 80.. 90.
 UNRESOLVED: libc++abi :: unwind_05.pass.cpp (40 of 41)
 ******************** TEST 'libc++abi :: unwind_05.pass.cpp' FAILED ********************
 Exception during script execution:
 Traceback (most recent call last):
   File "/home/abuild/rpmbuild/BUILD/llvm/utils/lit/lit/run.py", line 166, in execute_test
     result = test.config.test_format.execute(test, self.lit_config)
   File "/home/abuild/rpmbuild/BUILD/llvm/projects/libcxx/test/libcxx/test/format.py", line 51, in execute
     return self._execute(test, lit_config)
   File "/home/abuild/rpmbuild/BUILD/llvm/projects/libcxx/test/libcxx/test/format.py", line 76, in _execute
     script, tmpBase, execDir = res
 ValueError: need more than 0 values to unpack

 ********************

Since nothing changed on the build system I guess it should be a recent commit. I checked and res seems to be an empty array in the error case.

ismail


_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: libcxx tests broken?

Don Hinton via cfe-dev
Apparently fixed by r251529.

Sorry for the noise!

On Wed, Oct 28, 2015 at 5:55 PM, Ismail Donmez <[hidden email]> wrote:
Hi,

Since yesterday I am getting:

 ********************
 Testing: 0 .. 10.. 20.. 30.. 40.. 50.. 60.. 70.. 80.. 90.
 UNRESOLVED: libc++abi :: unwind_05.pass.cpp (40 of 41)
 ******************** TEST 'libc++abi :: unwind_05.pass.cpp' FAILED ********************
 Exception during script execution:
 Traceback (most recent call last):
   File "/home/abuild/rpmbuild/BUILD/llvm/utils/lit/lit/run.py", line 166, in execute_test
     result = test.config.test_format.execute(test, self.lit_config)
   File "/home/abuild/rpmbuild/BUILD/llvm/projects/libcxx/test/libcxx/test/format.py", line 51, in execute
     return self._execute(test, lit_config)
   File "/home/abuild/rpmbuild/BUILD/llvm/projects/libcxx/test/libcxx/test/format.py", line 76, in _execute
     script, tmpBase, execDir = res
 ValueError: need more than 0 values to unpack

 ********************

Since nothing changed on the build system I guess it should be a recent commit. I checked and res seems to be an empty array in the error case.

ismail



_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: libcxx tests broken?

Don Hinton via cfe-dev
On Wed, Oct 28, 2015 at 10:26 AM, Ismail Donmez via cfe-dev <[hidden email]> wrote:
Apparently fixed by r251529.

Sorry for the noise!

Thanks for the report.

-- Marshall

_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev