clang + cuda version issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

clang + cuda version issue

Deep Majumder via cfe-dev
I'm trying to get up and running with llvm/clang + cuda. llvm 11.0.1 successfully installed.

When I try to compile the simple example shown in llvm examples I get
clang-11: warning: Unknown CUDA version. cuda.h: CUDA_VERSION=11020. Assuming the latest supported version 10.1 [-Wunknown-cuda-version]
axpy.cu:23:7: error: use of undeclared identifier cudaConfigureCall
  axpy<<<1, kDataLen>>>(a, device_x, device_y);
I have cuda 11.2 installed however clang apparently needs cuda 10.1 and I'm running fedora 33 which is too new for cuda 10.1. cuda 10.1 is supported on fedora 29 but I don't wish to downgrade the os.

Is there any plan for llvm/clang to use newer cuda? on what time frame?

Thanks
Burlen





_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: clang + cuda version issue

Deep Majumder via cfe-dev
hmm, perhaps this is not the list to ask such a question. Does any one have insight to where a new user can get information about the plan for supporting more recent cuda versions? is there work in progress? is it documented somewhere?

Thanks
Burlen

On 1/19/21 8:50 PM, Burlen Loring wrote:
I'm trying to get up and running with llvm/clang + cuda. llvm 11.0.1 successfully installed.

When I try to compile the simple example shown in llvm examples I get
clang-11: warning: Unknown CUDA version. cuda.h: CUDA_VERSION=11020. Assuming the latest supported version 10.1 [-Wunknown-cuda-version]
axpy.cu:23:7: error: use of undeclared identifier cudaConfigureCall
  axpy<<<1, kDataLen>>>(a, device_x, device_y);
I have cuda 11.2 installed however clang apparently needs cuda 10.1 and I'm running fedora 33 which is too new for cuda 10.1. cuda 10.1 is supported on fedora 29 but I don't wish to downgrade the os.

Is there any plan for llvm/clang to use newer cuda? on what time frame?

Thanks
Burlen






_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev