Re: [llvm-dev] type traits bug in clang 4.0.0?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [llvm-dev] type traits bug in clang 4.0.0?

Xin Wang via cfe-dev
+clang mailing list, which has lots more C++/clang experts

On 3 July 2017 at 10:42, Christoph Höger via llvm-dev
<[hidden email]> wrote:

> Dear all,
>
> I found this strange behavior, when inspecting some legacy build that did
> not compile after an upgrade of several libraries and clang:
>
> https://stackoverflow.com/questions/44846377/what-is-the-reason-behind-instable-type-traits
>
> I got no conclusive answer, but a comment that indicates that this might
> indeed be a bug in clang. Since I am neither a C++ expert nor familiar with
> clang, I would very much appreciate if some expert could:
>
> 1. verify that this is indeed a bug
> 2. help me to formulate this as a constructive report (i.e. what is actually
> going wrong here w.r.t. the C++ standard) and/or further reduce the test
> case
>
> thanks a lot,
>
> Christoph
>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
>
_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [llvm-dev] type traits bug in clang 4.0.0?

Xin Wang via cfe-dev
I tried the posted code on SO and it also fails to compile on clang 5.0svn.

Cheers,
Michael Haidl

Mit TouchDown von meinem Android-Telefon gesendet (www.symantec.com)

-----Original Message-----
From: Diana Picus via llvm-dev [[hidden email]]
Received: Montag, 03 Juli 2017, 10:59
To: Christoph Höger [[hidden email]]; cfe-dev [[hidden email]]
CC: llvm-dev [[hidden email]]
Subject: Re: [llvm-dev] type traits bug in clang 4.0.0?

+clang mailing list, which has lots more C++/clang experts

On 3 July 2017 at 10:42, Christoph Höger via llvm-dev
<[hidden email]> wrote:
> Dear all,
>
> I found this strange behavior, when inspecting some legacy build that did
> not compile after an upgrade of several libraries and clang:
>
> https://stackoverflow.com/questions/44846377/what-is-the-reason-behind-instable-type-traits
>
> I got no conclusive answer, but a comment that indicates that this might
> indeed be a bug in clang. Since I am neither a C++ expert nor familiar with
> clang, I would very much appreciate if some expert could:
>
> 1. verify that this is indeed a bug
> 2. help me to formulate this as a constructive report (i.e. what is actually
> going wrong here w.r.t. the C++ standard) and/or further reduce the test
> case
>
> thanks a lot,
>
> Christoph
>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
>
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev

_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev
Loading...