LLVM on Windows MSVC 10

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

LLVM on Windows MSVC 10

Ruben Van Boxem
Hi,

I'm trying to build svn LLVM with Visual Studio 2010:

cd build
cmake .. -G"NMake Makefiles"
nmake

and several link steps fail due to a missing symbol:

> LLVMX86CodeGen.lib(X86JITInfo.cpp.obj) : error LNK2019: unresolved external symbol X86CompilationCallback referenced in function "public: virtual void (__cdecl*__cdecl llvm::X86JITInfo::getLazyResolverFunction(void * (__cdecl*)(void *)))(void)" (?getLazyResolverFunction@X86JITInfo@llvm@@UEAAP6AXXZP6APEAXPEAX@Z@Z)

What can/should I do?

Thanks!

Ruben

_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev
Reply | Threaded
Open this post in threaded view
|

Re: LLVM on Windows MSVC 10

Óscar Fuentes
[LLVM questions belong to [hidden email]]

Ruben Van Boxem <[hidden email]>
writes:

> I'm trying to build svn LLVM with Visual Studio 2010:
>
> cd build
> cmake .. -G"NMake Makefiles"
> nmake
>
> and several link steps fail due to a missing symbol:
>
>> LLVMX86CodeGen.lib(X86JITInfo.cpp.obj) : error LNK2019: unresolved
> external symbol X86CompilationCallback referenced in function "public:
> virtual void (__cdecl*__cdecl
> llvm::X86JITInfo::getLazyResolverFunction(void * (__cdecl*)(void
> *)))(void)"
> (?getLazyResolverFunction@X86JITInfo@llvm@@UEAAP6AXXZP6APEAXPEAX@Z@Z)
>
> What can/should I do?

It builds fine here on VS 10 Windows XP 32 bits with latests svn
sources.

_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev