ClangTooling compiling issues

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

ClangTooling compiling issues

David Zarzycki via cfe-dev
I am using Ubuntu 19.10, and I have just installed LLVM-10 as stated here [1].
Whenever I try to compile and link my project using LLVM-10 I get an error like this:
"/usr/lib/llvm-10/lib/XXX.a: error adding symbols: archive has no index; run ranlib to add one"
So, effectively, if I check the index of any of these static libraries I get:
# nm -s /usr/lib/llvm-10/lib/libclangTooling.a
nm: AllTUsExecution.cpp.o: file format not recognized
nm: ArgumentsAdjusters.cpp.o: file format not recognized
nm: CommonOptionsParser.cpp.o: file format not recognized
nm: CompilationDatabase.cpp.o: file format not recognized
nm: Execution.cpp.o: file format not recognized
nm: FileMatchTrie.cpp.o: file format not recognized
nm: FixIt.cpp.o: file format not recognized
nm: GuessTargetAndModeCompilationDatabase.cpp.o: file format not recognized
nm: InterpolatingCompilationDatabase.cpp.o: file format not recognized
nm: JSONCompilationDatabase.cpp.o: file format not recognized
nm: Refactoring.cpp.o: file format not recognized
nm: RefactoringCallbacks.cpp.o: file format not recognized
nm: StandaloneExecution.cpp.o: file format not recognized
nm: Tooling.cpp.o: file format not recognized

My question is, did I installed something wrong? Is this a buggy release or is this just because is under development?
Thank you!


_______________________________________________
cfe-dev mailing list
[hidden email]
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev