Clang-test build error

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Clang-test build error

kalyan ponnala
Hi,

I am trying to build the "clang-test" target in the visual studio's llvm solution file generated by cmake on a windows 7 64-bit system.
I can do an ALLBUILD properly without any errors.
But when I try to build the regression tests inside the "clang-test" target I get the following errors:
---------------------------------
1>------ Build started: Project: clang-test, Configuration: Debug Win32 ------
1>Running Clang regression tests
1>Traceback (most recent call last):
1>  File "C:/Users/KalyanPonnala/llvm/utils/lit/lit.py", line 4, in <module>
1>    import lit
1>  File "C:\Users\KalyanPonnala\llvm\utils\lit\lit\__init__.py", line 3, in <module>
1>    from lit import main
1>ImportError: cannot import name main
1>Project : error PRJ0019: A tool returned an error code from "Running Clang regression tests"
1>Build log was saved at "file://c:\Users\KalyanPonnala\llvm\binaries\tools\clang\test\clang-test.dir\Debug\BuildLog.htm"
1>clang-test - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 54 up-to-date, 0 skipped ==========
----------------------------------

This was the procedure pointed out at the following website:
 http://clang.llvm.org/hacking.html#testingWindows

Can someone tell why am I getting this error?

Thanks
--
Kalyan Ponnala
phone: 8163772059

_______________________________________________
cfe-dev mailing list
[hidden email]
http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev